jQuery 2.x on Digital Factory 7.1.0.1

  Written by The Jahia Team
 
Developers
  jquery
   Estimated reading time:
7.1.0.1

Is it possible to use another JQuery version than the one embedded with Digital Factory 7.1.0.1?

Answer

Currently, the JQuery module used by Digital Factory 7.1.0.1 is the version: 1.10.2

This is documented in our documentation at this link: https://www.jahia.com/community/extend/developers-techwiki/look-and-feel-styling/using-jquery

However, this is possible to create his own JQuery module with a version of the branch 1.x but the risk is the following one:

But you have to take care to override all views of Jahia components that use JQuery in order to load your own module and validate that it still works with this JQuery version. Create your own version of the existing JQuery module, but we cannot guaranty that our module will still continue to work as expected.

Finally, the JQuery 2.xx is not planned to be supported in Jahia 7.1.x.