Upgrade fails (build number does not match)

  Written by The Jahia Team
   Estimated reading time:
7.1.2.1

Upgrade fails with

ERROR: detected installed build number does not match fix build number!

Cause

The jahia-impl-*.jar has incorrect build number.

Solution

To apply the fix, the default filejahia-impl-*.jar must be present with the correct build number.
If the customer has the correct jar available, replace the existing one in WEB-INF/lib/ with it. Else do a fresh install of required version and copy the jar generated.