Written by The Jahia Team
 
Developers
Sysadmins
   Estimated reading time:

Jahia 8 only supports Forms. Form Factory 2.3 is not compatible with Jahia 8 and must be upgraded before you migrate from Jahia 7.3 to 8. If you were on Form Factory, you must first migrate to Forms while still running Jahia 7.3. See Upgrading to Forms from Form Factory. Once you have migrated to Forms 2.4 on your Jahia 7.3, then you can migrate to Jahia to 8.

To migrate from Forms 2.4 to Forms 3.0 on Jahia 8, you need only to update the modules you are using from Forms in your digital-factory-data/modules folder. Remove the older versions and copy the new ones. This is presented in detail in step 4 of the How to upgrade guide, which explains how to run the Jahia fix applier.

All new versions will be available on the Store for download to prepare your migration.

Please see the System administrators migration guide for more details.