Written by Florent Bourass√© (Customer Support team)
 
Sysadmins
   Estimated reading time:

After a restart, Jahia does not start anymore and the log contain the following error message:

Invalid version number: Version number may be negative or greater than 255

Cause

There is a very high probability that before the restart, your JDK has been upgraded to a version greater than 255, leading to a known bug in the library icu4J (cf internal ticket QA-13064).

Solution

If you're unable to upgrade to the OpenJDK 11, please follow these steps for each Jahia node:

  • Stop your node
  • Rename the library TOMCAT_HOME/webapps/ROOT/WEB-INF/lib/icu4j-4.0.1.jar with the suffix .bak
  • In the same folder, add the library icu4j-67.1.jar
  • Start your node