cfg config jexperience osgi upgrade System Administrator Jahia 7.3

jExperience not starting after an upgrade

Question

After upgrading jExperience from 1.11.0 to 1.11.3, we can see such messages in the logs: 

2020-12-07 18:13:15,091: ERROR [configadmin] - Cannot use configuration org.jahia.modules.jexperience.settings.a79017e9-4cd9-4211-adcc-05852a0d5f72 for [org.jahia.modules.jexperience.admin.JExperienceConfigFactory, org.osgi.service.cm.ManagedServiceFactory, id=225, bundle=220/dx:org.jahia.modules/jexperience/1.11.3]: No visibility to configuration bound to dx:org.jahia.modules/jexperience/1.11.0
2020-12-07 18:13:15,091: ERROR [configadmin] - Cannot use configuration org.jahia.modules.jexperience.settings.71870a97-3b50-4003-8872-fad5f18281e1 for [org.jahia.modules.jexperience.admin.JExperienceConfigFactory, org.osgi.service.cm.ManagedServiceFactory, id=225, bundle=220/dx:org.jahia.modules/jexperience/1.11.3]: No visibility to configuration bound to dx:org.jahia.modules/jexperience/1.11.0

 

 

Cause

It seems that you have multiple versions of jExperience on your platform. There is a known issue with modules using cfg file: cfg files binds to the first module it sees. 

Solution

So you either need to remove older versions of jExperience, or from osgi config manager manually point to new version.