ldap
System Administrator
Legacy
LDAP provider is stopped periodically
Question
The customer has noticed that the LDAP provider is stopped periodically and users are not able to get in the site.
Cause
According to the jahia.log file, an LDAP search was timed out after 5 seconds and the consequence is that the LDAP provider is stopped:
2016-06-30 09:30:40,991: ERROR [ramScheduler_Worker-2] org.jahia.services.usermanager.ldap.communication.BaseLdapActionCallback: An error occurred while communicating with the LDAP server ldap
org.springframework.ldap.UncategorizedLdapException: Uncategorized exception occured during LDAP processing; nested exception is javax.naming.NamingException: LDAP response read timed out, timeout used:5000ms.; remaining name &'cn=users,DC=SODEXO,DC=COM&'
Solution
The solution is to increase the LDAP read timeout and to increase other timeouts as well.
Here are the values to update:
user.ldap.connect.timeout=10000
user.ldap.read.timeout=10000
user.ldap.connect.pool.timeout=10000
Here is our LDAP Connector details for more details: https://www.jahia.com/community/extend/developers-techwiki/users-and-groups/ldap-connector-71