Upgrading to jExperience 3.3.0

January 9, 2024

Before upgrading jExperience or jCustomer, please make sure to review this page on the Academy containing upgrade recommendations.

Upgrade path

Upgrading to jExperience 3.3.0 requires an upgrade of jCustomer to version 2.4.0.

Although the upgrade of the jExperience module is straightforward, you must understand what changes are needed for your codebases to be compatible with this new major version of the backend (and the introduction of JSON Schemas).

Instructions to upgrade jCustomer are available in a dedicated section of the academy.

Note

Starting with Jahia 8.1.2.0, Jahia is checking if upgrading the module introduces changes in its definition. If such changes are detected, the default Jahia behavior will be to reject a module upgrade.

jExperience comes with its own migration mechanism to handle changes in definitions, when updating jExperience via Jahia's module manager, it is therefore safe to ignore definition checks via the UI, unselecting "Validate module definitions", or via the API using the "ignoreChecks" boolean.