jCustomer 1.5.4 - Release notes

  Written by The Jahia Team
 
Sysadmins
   Estimated reading time:

jCustomer 1.5.4 is compatible with jExperience 1.11.3 (Jahia 7.3.x) and jExperience 1.12.x (Jahia 8.x) along with Elasticsearch-7.4.x.

How to upgrade to jCustomer 1.5.4 instructions are available:

jCustomer 1.5.4

jCustomer 1.5.4 is the latest version of jCustomer which is compatible with Jahia 7.3.x and Jahia 8.x

Release notes

See also release notes of Unomi 1.5.3 and 1.5.4

Security fix

Bugfixes

  • Merge Profiles On Property Action Fails Without session
  • Stop jCustomer in case of an error which its cannot recovery from
  • Can't create segments
  • Delete Segment has an error
  • Default allow-list for expression filter not properly loaded from config
  • Implement PropertyConditionEvaluator hardcoded property accessors
  • Wrong classloader used in MvelScriptExecutor

New feature

  • Support_addValues

Improvement

  • Introduce double value to condition parameter
  • Optimize past event queries
  • Cookie profile id should be SameSite=Lax