Written by The Jahia Team
 
Developers
Sysadmins
   Estimated reading time:

General information

Read all of the instructions on this page carefully before proceeding with the upgrade process.
Run a pre-production test first.
  • Update is only required if Jahia has been updated from Jahia 7 to Jahia 8
  • jExperience 1.12 is compatible with jCustomer 1.5.1 and only with Jahia 8.0.0.0+
  • jCustomer 1.5.1 relies on Elasticsearch 7.4.2. This change of Elasticsearch version, from 5.7.3 to 7.4.2 is the reason why Unomi data needs to be migrated. 
  • While jExperience module is stopped or jCustomer not available, no events are tracked and no personnalised or optimised (A/B test) content is displayed to users.

Update path:

Update Jahia 7 to Jahia 8 but don't start Jahia until jCustomer is migrated. 

Follow instructions from https://academy.jahia.com/cms/render/default/customer-center/jahia/how-to-upgrade/7.3.4.1-8.0.0.0 but do not start jahia until jCustomer is migrated. 

Migrate jCustomer from 1.4.1 to 1.5.1

To migrate from jCustomer 1.4.1 to 1.5.1 , please follow the procedure described in Unomi documentation. 

Any mention of "Unomi 1.4.0" can be interpreted as jCustomer 1.4.1

https://unomi.apache.org/manual/latest/index.html#_data_model_changes_for_apache_unomi_1_5_0 

Start Jahia

As jExperience 1.11.0 is not compatible with Jahia 8, it won't be started.

Install jExperience 1.12.0 module and start it.

Get jExperience from the the Jahia store and install it from the administration / Modules and extensions panel.

Or download and install the new version directly from the Modules and extensions panel if the store is available. 

Screenshot 2020-05-20 at 13.20.43.png

Any way you use to deploy new version of a module will work. 

Start the module.

You have to update and start jExperience to 1.12 AFTER jCustomer being migrated to 1.5.1. 

Enjoy jExperience 1.12.0 on Jahia8!