Upgrading to jExperience 2.7.2

January 9, 2024

Before upgrading jExperience or jCustomer, please make sure to review this page on the Academy containing upgrade recommendations.

Upgrade path for jExperience 2.2.1 and below

jExperience 2.7.x requires at a minimum jCustomer 1.6.0 (jCustomer 1.9.0 recommended), and since versions of jExperience 2.2.1 and below are not compatible with jCustomer 1.6.0, you will likely need to update both products.

For environments running jExperience 2.2.1, the recommended upgrade path is as-follow:

  • Upgrade to jExperience 2.2.2. If you were previously running jExperience 2.2.1, this upgrade should be seamless, as jExperience 2.2.2 does not introduce changes other than support for jCustomer 1.6.0 (in addition to supporting jCustomer 1.5.6+)
  • Upgrade to jCustomer 1.9.0.
  • Upgrade to jExperience 2.7.x (this page)

Install jExperience 2.7.x module and start it.

Get jExperience from the the Jahia store and install it from the administration / Modules and extensions panel. 

Or download and install the new version directly from the Modules and extensions panel if the store is available. 

jExperience-2.7.x requires Jahia 8.1.0.0+ and jCustomer 1.6.0.

If you are already using jCustomer 1.6.0, you just need to execute the following steps:

  1. Upload and start jExperience 2.7.x module as you would do for any other module.
  2. Remove all previous jExperience versions

About the new proxy configuration

Updating jExperience does not modify your existing configuration during the update process, to benefit from the new configuration, you will need to edit your configuration file and add the new configuration manually.

Note

Starting with Jahia 8.1.2.0, Jahia is checking if upgrading the module introduces changes in its definition. If such changes are detected, the default Jahia behavior will be to reject a module upgrade.

jExperience comes with its own migration mechanism to handle changes in definitions, when updating jExperience via Jahia's module manager, it is therefore safe to ignore definition checks via the UI, unselecting "Validate module definitions", or via the API using the "ignoreChecks" boolean.